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1 Introduction 

1.1 Purpose of this document 

This documents explains how to use the Proposal Generation Tool (PGT) software to prepare (and 
submit to ISOC) a science proposal for use with the INTEGRAL Observatory. 

1.2 Intended readership 

Observers wishing to apply with for science time with INTEGRAL. Proposals can only be 
submitted with the PGT. 

1.3 The Proposal Generation Tool 

PGT is the tool to generate and submit science proposals for use with the INTEGRAL Observatory. 
PGT is organized in terms of panels, all accessible from the so-called Main Panel, the starting point 
when running PGT. The Main Panel acts as a parent for the rest of panels, on which the 
administrative and techinical details of the proposal and submitter can be enterend. The Main panel 
then allows proposal checking and submission to ISOC, at the end of the data entry process. 

1.4 Online tools 

Two online tools are provided to aid proposal writing: The Observation Time Estimator (OTE) and 
the Target Visibility Predictor (TVP). The tools can be accessed on the ISOC website, at: 

http://integral.esac.esa.int 

For instructions on their use, please refer to the respective user manuals that are available on the 
above address as well. 

1.5 Problem reporting 

If you discover a problem with the PGT, your first port of call should be the Frequently Asked 
Questions (FAQ) page on the Integral Web Site found at this location: 

http://integral.esac.esa.int 

If this does not answer your query, then you can send a message to the Helpdesk at the following 
email address: 

inthelp@sciops.esa.int 

1.6 References 

RD-1 INT/SDG/06-0250-Dc Integral Mission Overview, Policies and 
Procedures 
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RD-2 INT-SOC-DOC-023 JEM-X Observer’s Manual 

2 Installing the Proposal Generation Tool 
The PGT can be downloaded from the Integral website: 

http://integral.esac.esa.int/isoc/operations/html/pgtao5kp/ 

Installation instructions and answers to frequently asked questions are provided there also. 

The method of starting the PGT depends on the platform. UNIX users start the PGT by running a 
script, whereas Windows users double click on a desktop icon. Detailed information is provided on 
the Integral website. 

3 Entering Data 

3.1 The Main Panel 

When the PGT is first started, the Main Panel is displayed. This panel acts like the parent for all 
other panels and it is from this panel that you can access the other panels of the PGT. 

 
Figure 1 - The Main Panel 

The Main Panel is divided into two sections. The top half of the panel contains buttons, which open 
other panels. These panels are described in later sections of this document. In addition, there is a 
Check Proposal button, which will run a series of checks on your proposal and list anything that is 
wrong or incomplete. This check can be performed at any time. 

The lower half of the Main Panel is devoted to proposal submission. With the Submit Proposal to 
ISOC button you are able to electronically send your proposal to the ISOC. See section 5, for more 
details on submitting a proposal. 
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3.2 Details Panels 

The PGT uses three details panels to allow information about the proposal be entered: Proposal 
details, administrative details, and observation details. Clicking their respective buttons on the main 
panel opens the panels. 

3.3 Attaching the scientific justification 

At the bottom of the Proposal Details Panel is a button marked New Attachment. Use this button to 
attach the scientific justification of your proposal in PostScript or PDF format. 

 
Figure 2 - Adding Attachments 

Once you select the New attachment button, the name of your attachment will be shown in the 
Current Attachment box of the Proposal Details Panel (see Figure 2). If you save your proposal, the 
attachment will be saved with it (in compressed form), so there is no need to re-attach the file every 
time the proposal is loaded. However, if you make changes to your scientific justification after 
attaching the file to your proposal, you will need to re-attach the changed file. 

There are differences in the requirements on the scientific justification between normal AO’s and 
Key Programme AO’s. The requirements for Key Programme AO’s are detailed in the document 
“Announcement of Opportunity for Key Programme Observing Proposals for the AO-5 Observing 
Cycle” (ref. INT/SDG/06-249/Dc), paragraph 2.2.1. 

Note that it is not possible to remove an attachment on its own (you can select Reset from the Panel 
menu and this will remove the attachment, but it will also clear the other fields). However, you can 
replace the existing attachment with another one at any time, simply by using the Attach dialogue 
again. 
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3.4 Observation Details 

Each observation in a proposal is numbered sequentially, as shown in the Number field on the left 
of the tool bar at the top of the Observation Details Panel. Here, you can see the number of the 
currently displayed observation and the total number of observations in the proposal. 

Whenever an observation is added to a proposal, it is added at the end of the list. For example, 
adding an observation to a proposal, which contains ten observations, will result in the new 
observation being given the number eleven. When removing an observation, those observations 
with a higher number than the observation, which was removed, will have their numbers reduced by 
one. For example, removing observation number five from a proposal which contains ten 
observations will result in observation numbers six to ten being renumbered five to nine 
respectively. 

The pattern centre is required for any of the available dither pattern types. If Custom Dither is 
chosen as the pattern type, pattern details must be provided in the scientific justification (see the 
document reference in section 3.3). 

 
Figure 3 - The Observation Details Panel 

3.4.1 The Observation Menu 
The Observation Details Panel has an additional menu, named Observation. 
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Figure 4 - The Observation Menu 

Using this menu you can manipulate observations in your proposal. The menu entries should be 
self-explanatory: to add a new observation, select Add (the display will show the new observation); 
to remove the currently displayed observation, select Delete; to copy the currently displayed 
observation, select Duplicate (the display will show the copied observation); to check the currently 
displayed observation, select Check; to display a particular observation, select Go To. 

3.5 Mandatory Items 

Mandatory fields are fields that you must complete. They are denoted by a coloured background.  

Mandatory
fields

 
Figure 5 - Example of Mandatory Fields 

 

4 Saving, Loading and Printing 
A proposal may be saved at any time by selecting the Save menu entry in the File menu of the Main 
Panel (see Figure 1). To load a proposal, select the Open menu entry in the File menu of the Main 
Panel.  

4.1 Printing 

The paper size and the font used for printing can be chosen using the Print Options dialogue. To 
open this, select the Options menu entry from the Print submenu in the File menu of the Main 
Panel (see Figure 1). 
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Figure 6 - The Print Options Dialogue 

Two paper sizes are supported, A4 and US letter. Click on the appropriate button at the top of the 
dialogue to choose the paper size. 

The central part of the dialogue lists the fonts available on your system. This list will vary from one 
machine to another, but there are five standard fonts, which are available on every system. These 
are: Dialog, DialogInput, Monospaced, SansSerif and Serif. A sample of the selected font is shown 
below the font list. 

To make the selected font and paper size the current (active) choices, click OK. To disregard the 
selections and close the dialogue, click Cancel. 

4.1.1 Printing a Proposal entirely or in parts 
The File menu on the Main Panel has a Print submenu. To print a complete proposal, including all 
observations, choose Proposal in this submenu. A Print dialogue will appear which will allow you 
to select a destination for the print job (printer or file) and to start the print job. The exact 
appearance of this dialogue will depend on the platform you are using. 

The administrative details, the proposal details and the observation details can be printed 
individually by choosing Print from the Panel menu in the respective panels. 

To print an individual observation, make sure the observation is displayed in the Observation 
Details Panel and choose Current Observation from the Print submenu in this panel. To print all 
the observations, choose All Observations. 

A summary of all the observations in the proposal (one observation per line) can be printed by 
choosing Summary from the Print submenu in the Panel menu of the Observation Details Panel. 
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5 Submitting a Proposal to ISOC 
The PGT allows you to send your proposal electronically to the ISOC. In order for this to work, 
your computer must be connected to the Internet. 

5.1 Submitting for the first time 

The lower half of the Main Panel (see Figure 1) allows you to submit your proposal to the ISOC 
when it is complete and you are happy with it.  

Clicking the Submit Proposal to ISOC button starts the submission process. First, the PGT will 
check your proposal. If it fails any checks, the submission process will be aborted and you will need 
to correct the errors shown in the Failed Checks Panel. If it passes the checks, a panel is displayed 
showing a summary of the proposal. Click Submit to send the proposal, Cancel to abort the 
submission. 

One of the checks is the confirmation of the source coordinates entered against the Simbad 
database. In case the name of your source is not known to Simbad, or if the coordinates deviate, a 
warning is printed in the Failed Checks Panel. If your PC is not connected to the internet, a warning 
to this effect is printed also. These are nothing more than warnings for your convenience. You will 
still be able to submit your proposal, although obviously for submission an internet connection is 
required. 

 
Figure 7 - The Summary Panel 
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If you click Submit, the PGT will attempt to establish contact with a computer at the ISOC which 
has been set up to receive proposals. Once contact is established, your proposal will be sent. If the 
proposal was sent successfully, the dialogue shown in Figure 8 will be displayed. 

 
Figure 8 - Successful Submission Dialogue 

When it receives your proposal, the computer at the ISOC will check the proposal (these checks are 
different from those performed by the PGT) and return an email message to you confirming receipt 
and providing a Proposal ID for your proposal (you will need this ID if you want to resubmit the 
proposal). The message will also tell you whether your proposal has been accepted (it passed the 
checks) or rejected (it failed the checks). 

5.2 Repeating a Submission 

If you realise you have made a mistake, or you just want to make changes to a proposal you have 
already submitted, you can resubmit a proposal using the Proposal ID you received when you 
submitted the proposal for the first time. 

Make the changes you wish to make to the proposal and enter the Proposal ID in the box provided 
at the bottom of the Main Panel (see Figure 1). The Resubmit Proposal to ISOC button will be 
enabled and the Submit Proposal to ISOC button will be disabled (to prevent you pressing the 
wrong button). When you click the Resubmit Proposal to ISOC button, the PGT will repeat the 
proposal submission process, described in section 5.1 

The computer at ISOC will use the Proposal ID you provide to find your old proposal in the ISOC 
database. If it is found, your amended proposal will replace the old one in the ISOC database. If it 
can’t be found, the email message which is returned to you will inform you of that fact (make sure 
you have entered the Proposal ID correctly). 

It is not allowed change the “Associate to Key Programme” checkbox on the Proposal Details 
Panel, and resubmit. The reason is that proposal ID is different for a proposal that is associated to a 
Key Programme, and a proposal that is not. You are therefore not allowed to change this checkbox 
and re-use the same ID. In this case, when the “Associate to Key Programme” checkbox must be 
changed, simply submit the proposal without specifying the ID. You will then be given a new ID 
that is compatible with your selection. 
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NOTE: The PGT cannot prevent you submitting the same proposal multiple times. Each time you 
submit a proposal, you will receive a new Proposal ID. It is not possible to undo a submission, so if 
you want to avoid having duplicate (or very similar) proposals in the ISOC database (each of which 
will be reviewed by the TAC), use the Resubmit Proposal to ISOC button when you need to make 
changes to a previously submitted proposal. 

5.3 Obtaining a Copy of a Submitted Proposal from ISOC 

Once you have submitted your proposal, you should save it (see Section 4) to ensure you have a 
copy on your local system for your own reference, and to allow you to resubmit the proposal at a 
later date. 

You can also request a copy of your proposal by sending an email to the ISOC Helpdesk at the 
email address listed in section 1.5. Just state in the body of the message that you would like a copy 
of your proposal and give the Proposal ID of the proposal. The proposal will be emailed to you at 
the e-mail address you entered into the proposal. If this is not what you want, you should provide 
the correct address in your email to the Helpdesk. 
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Appendix A: Keyboard Shortcuts 

Main Panel 
Key Press Function 

ALT-A Open the Admin Details Panel 
ALT-C Check Proposal 
ALT-E Open the Observation Time Estimator 
ALT-F Open the File menu 
ALT-F E Exit the PGT 
ALT-F O Open the Open dialogue 
ALT-F P Open the Print submenu 
ALT-F P O Open the Print Options dialogue 
ALT-F P P Print the Proposal 
ALT-F S Open the Save dialogue 
ALT-H Open the Help menu 
ALT-H A Open the About dialogue 
ALT-H O Open the Overview Panel 
ALT-H N Open the Main Panel Help 
ALT-O Open the Observation Details Panel 
ALT-P Open the Proposal Details Panel 
ALT-V Open the Target Visibility Predictor 
CTRL-E Exit the PGT 
CTRL-H Open the Main Panel Help 
CTRL-O Open the Open dialogue 
CTRL-S Open the Save dialogue 

Admin Details Panel 
Key Press Function 

ALT-H Open the Help menu 
ALT-H N Open the Admin Details Panel Help 
ALT-H O Open the Overview Panel 
ALT-P Open the Panel menu 
ALT-P E Close the Admin Details Panel without losing data 
ALT-P R Reset the Admin Details Panel fields to their default settings 
ALT-P T Print the admin details 
CTRL-E Close the Admin Details Panel without losing data 
CTRL-H Open the Admin Details Panel Help 
CTRL-P Print the admin details 
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CTRL-R Reset the Admin Details Panel fields to their default settings 

Proposal Details Panel 
Key Press Function 

ALT-H Open the Help menu 
ALT-H N Open the Proposal Details Panel Help 
ALT-H O Open the Overview Panel 
ALT-P Open the Panel menu 
ALT-P E Close the Proposal Details Panel without losing data 
ALT-P R Reset the Proposal Details Panel fields to their default settings 
ALT-P T Print the proposal details 
CTRL-E Close the Proposal Details Panel without losing data 
CTRL-H Open the Proposal Details Panel Help 
CTRL-P Print the proposal details 
CTRL-R Reset the Proposal Details Panel fields to their default settings 

Observation Details Pane 
Key Press Function 
ALT-H Open the Help menu 
ALT-H N Open the Observation Details Panel Help 
ALT-H O Open the Overview Panel 
ALT-O Open the Observation menu 
ALT-O A Add an observation to the proposal 
ALT-O C Check the current observation 
ALT-O D Delete the current observation from the proposal 
ALT-O G Go to a specific observation 
ALT-O U Copy an observation and add it to the proposal 
ALT-P Open the Panel menu 
ALT-P E Close the Observation Details Panel without losing data 
ALT-P R Reset the Observation Details Panel fields to their default settings 
ALT-P T Open the Print submenu 
ALT-P T A Print the details of all observations 
ALT-P T C Print the details of the current observation 
ALT-P T S Print a summary of all observations 
CTRL-E Close the Observation Details Panel without losing data 
CTRL-H Open the Observation Details Panel Help 
CTRL-P Print all observation details 
CTRL-R Reset the Observation Details Panel fields to their default settings 

 


