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1 Introduction

1.1 Purpose

This document explains how to use the Proposal Generation Tool (PGT) software 
to prepare a science proposal for use with the INTEGRAL Observatory. It explains 
the use of the software from a functional, rather than scientific, point of view.

1.2 Intended Readership

Observers wishing to apply for science time on INTEGRAL should familiarise 
themselves with this document and keep it handy to use as a reference. Proposals 
for INTEGRAL can only be created and submitted by using the PGT software.

1.3 Using Online Help

The online help provides brief explanations for most of the fields in the PGT and is 
accessed from the Help menu (see section 2.3, page 6).

1.4 Using the SUM

This document provides more detailed explanations of the PGT functionality than 
the online help can provide. However, the PGT is not a difficult tool to use and once 
you are familiar with the basics, you should not need to refer to this document very 
often.

1.4.1 Conventions Used
The labels used for items in panels are shown in italics. Items in a panel which 
cause an action to be performed are shown in bold.

1.5 Problem Reporting

If you discover a problem with the PGT, your first port of call should be the 
Frequently Asked Questions (FAQ) page on the Integral Web Site (IWS) found at 
this location:

http://astro.esa.int/Integral/isoc/

If this does not answer your query, then you can send a message to the Helpdesk at 
the following email address:

inthelp@rssd.esa.int
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1.6 Definitions, acronyms and abbreviations

1.6.1 Definition of Terms

The definition of terms is provided in [AD-2].

1.6.2 Acronyms

ADS Archive and Distribution System
AO Announcement of Opportunity
API Application Programming Interface
CSSW Common Services Software
DBOB Data Base of Observable Bins
ECS Exposure Completion Status (file)
ED Event Designator
EID Experiment Interface Document
ESA European Space Agency
ESOC European Space Operations Centre
ESTEC European Space Technology and Research Centre
FE Front-End
FOV Field of View
FTP File Transfer Protocol
GO General Observer
GPC Galactic Plane Core
GPS Galactic Plane Survey
CPWG Core Programme Working Group
GUI Graphical User Interface
IASW Instrument Application Software
IBIS Gamma-ray Imager
ICD Interface Control Document
ICCS ISOC Configuration Control System
IFTS INTEGRAL File Transfer System
INTEGRAL International Gamma-Ray Astrophysics Laboratory
IOP Initial Observations Parameters
ISO Infrared Space Observatory
ISOC INTEGRAL Science Operations Centre
ISDC INTEGRAL Science Data Centre
ISWT INTEGRAL Science Working Team
JEM-X X-ray Monitor
LAN Local Area Network
MIRD Mission Implementation Requirements Document
MOC Mission Operations Centre
MOUT Message Out
MP Mission Planner
OBSW On-board Software
OCS Observation Completion Status (file)
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OGS Operational Ground Segment
OMC Optical Monitor Camera
OPP OMC Pointing Parameters
OSS Observation Scheduling System
PA Product Assurance
PAD Proposal Administrative Data
PAS Performance Analysis Subsystem
PDC Problem Domain Component
PGT Proposal Generation Tool
PH Proposal Handler
PHS Proposal Handling System
PI Principal Investigator
POD Planning and Observation Data
POS Preferred Observation Sequence
PA Product Assurance
PS Project Scientist
PSF Planning Skeleton File
SCMP Software Configuration Management Plan
SGS Science Ground Segment
SGSIP SGS Implementation Plan
SGSM Science Ground Segment Manager
SGSRD SGS Requirements Document
SPI Gamma-ray Spectrometer
SPMP Software Project Management Plan
SPAP Software Product Assurance Plan
SVT System Validation Test
SVVP Software Verification and Validation Plan
TAC Time Allocation Committee
TM Telemetry
TOO Target Of Opportunity
URL Universal Resource Locator
WWW World Wide Web
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1.7 References

1.7.1 Applicable documents

The following documents are applicable in their latest version (except PSS-05):

AD-1 PSS-05-0 ESA Software Engineering Standards, Issue 2
AD-2 INT-SOC-DOC-002 Definition of Observations Terms
AD-3 INT-SOC-URD-001 ISOC URD
AD-4 INT-SOC-SRD-002 ISOC SRD
AD-5 INT-SOC-PL-005 ISOC SPAP
AD-6 INT-SOC-PL-002 ISOC SCMP
AD-7 INT-SOC-PL-003 ISOC SVVP
AD-8 INT-SOC-ICD-001 ISOC - ISDC ICD
AD-9 INT-SOC-ICD-002 ISOC - OMC ICD
AD-10 INT-MOC-SYS-ICD-0001 OGS - SGS ICD
AD-11 INT-SOC-DOC-003 ISOC infrastructure
AD-12 INT-SOC-PL-004 ISOC SPMP

1.7.2 Reference documents

RD-1 INT-SOC-DOC-001 ISOC Operations Concept
RD-2 INT-SYS-MIS-TN-0002-SMD INTEGRAL Mission Planning Concept
RD-3 Coad P., Yourdon E; Object-Oriented Design; 

Prentice Hall 1991
RD-4 BSSC ESA; Issue 1 Draft 2 Guide To Applying ESA software engineering 

standards to projects using OO Methods; July 1997
RD-5 Design Patterns; Addison Wesley 1994; 

Gamma E. et Al.
RD-6 INT-SR-1594 SGS Requirement Document
RD-7 INT-PL-03197 SGS Implementation Plan
RD-8 INT-IC-AI-0005 Satellite Database ICD
RD-9 INT-RP-AI-0030 Packet Structure Definition
RD-10 INT-SAG-98-0042-TN Instrument Modes and Mode Transitions Supported 

by ISOC
RD-11 INT-SOC-DOC-023 JEM-X Observer’s Manual



esa
INTEGRAL

ISOC

Proposal Generation Tool SUM

Doc.No : INT-SOC-SUM-018
Issue : 1.2
Date : 9th  June  2004 
Page No : 5
2 Proposal Generation Tool Conventions

2.1 Common Panel Layout

Every panel shares a common layout. This layout consists of a menu bar at the top 
of the panel with an icon strip underneath it. The icon strip usually contains the ESA 
logo, the ISOC logo and the Integral logo. Below the icon strip is a scrollable area 
containing the main body of the panel. When a panel is first opened it will be shown 
at its default size. If you resize the panel so that it is smaller than this default size, 
scroll bars will automatically appear and you can use these to view the hidden parts 
of the panel.

Figure 1   Common Panel Layout

At the bottom of every panel is a message bar. Informative messages may appear 
here from time to time.

2.2 Mandatory Fields

Mandatory fields are fields which you must complete. They are denoted by a 
coloured background. By default, they are coloured cyan, though you may choose 
a different colour by editing the PGT.lax file (see section 8.2, page 26).

Figure 2   Example of Mandatory Fields

Icon strip

Menu bar

{Main body of panel
Scroll bars

Message bar

Mandatory
fields
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2.3 Help Menu

Menus are located on the menu bar at the top of every panel (see section 3.4.3, page 
8, and section 3.5.2, page 9, for details of the different ways of accessing menus). 
One menu which is common to all panels in the PGT is the Help menu. This menu 
contains at least two entries: Panel and Overview.

The Panel entry causes a help panel to be displayed which provides information 
about the panel to which the help menu belongs. The Overview entry opens a help 
panel which contains an overview of the major functionality in the PGT. This 
overview is the same no matter which Help menu was used to activate it.

Figure 3   Example Help Panel

2.4 Panel Menu

Every panel, except the Main Panel, contains a Panel menu with some or all of the 
entries Reset, Print and Hide.

The Reset entry allows the user to reset all the inputs in the current panel to their 
default values.

The Print entry allows the contents of some panels to be sent to a printer.

The Hide entry closes the current panel, but preserves any data entered into any of 
the fields. This means that if the panel is reopened, the data will be visible again.
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3 Proposal Generation Tool Basics

3.1 Installing the Proposal Generation Tool

The PGT is written in the Java programming language and, as such, is platform 
independent, meaning that the same software will run on many operating systems 
without modification. However, in order to ease installation on different platforms 
and to allow local customisation of certain parameters, the PGT is provided in a 
variety of platform specific packages. These packages can be found on the Integral 
Web Site (see section 1.5, page 1, for the URL).

To install the package for a given platform, follow the instructions in the 
README.txt file which can also be found on the Integral Web Site.

3.2 Starting the Proposal Generation Tool

The method of starting the PGT depends on the platform in use. UNIX users start 
the PGT by running a script, whereas Windows users double click on a desktop 
icon. The README.txt file provides details of how to start the PGT.

3.3 Enabled and Disabled Fields

Certain fields can become disabled or enabled depending on which selections or 
settings are made to other fields in a panel. When a field is disabled, it is shown with 
gray text on a gray background, and when it is enabled, it is shown with black text 
on a gray or coloured (if it is a mandatory field) background.

Figure 4   Enabled and Disabled Fields

3.4 Using the Mouse

The mouse is used to move an on-screen pointer and to trigger events, such as 
activating menus and buttons, making selections from pick-lists, moving the input 
focus from one field to another and changing the positions of scrollbars.

Disabled fields

Enabled field

Enabled
fields
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3.4.1 Terminology

“Clicking” refers to pressing the left-hand mouse button while the pointer is over 
an item you want to activate. For example, “click the OK button” means move the 
pointer to the OK button and press (and release) the left-hand mouse button.

“Right-clicking” refers to clicking using the right-hand mouse button instead of the 
left-hand one.

“Dragging” refers to holding a mouse button down whilst moving the pointer.

3.4.2 Input Focus
Data can be entered into only one field at a time. Similarly, only one button, menu 
item or pick-list can be activated at a time. The item which is currently active, that 
is, receiving input, is said to have the “input focus”. Text entry fields are signified 
as having the input focus by a vertical bar (called the “caret”) which usually flashes. 
Buttons and pick-lists have a faint rectangular box within them, if they have the 
input focus. To transfer the input focus from one item to another, click on the item 
you want to transfer the input focus to.

3.4.3 Menus
To open a menu, click on the name of the menu you wish to open in the menu bar 
(see Fig. 1) of the panel. To select an entry from the menu, click on the entry. An 
alternative way of making menu selections is to hold the mouse button down over 
the menu bar and when the menu appears, drag the pointer to your selection; when 
you release the mouse button, the entry under the pointer will be activated.

3.4.4 Pick-Lists
A pick-list can be opened by clicking on it. To make a selection from the list, click 
on the entry you want to select from the list.

Figure 5   Using Pick-Lists

If the list has many entries, not all will be visible at once and a scrollbar will be 
shown to the right of the list. You can use this scrollbar to make visible the entries 
in the list which are currently hidden. In order to make use of the scrollbar, you must 

Click here to move
up the list

Click here to move
down the list

Drag the scrollbar
to move up or down
the list
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not hold the mouse button down when you open the pick-list. If you do hold the 
mouse button down and drag the pointer, you will only be able to select the entries 
which are currently visible, because the pick-list will close as soon as you release 
the mouse button.

3.4.5 Buttons and Check Boxes
To activate a button, just click on it. Similarly, to toggle the state of a check box, 
click on it.

3.5 Using the Keyboard

It is possible to use the majority of the PGT using only the keyboard. Most of the 
functionality of the mouse can be replicated with a few simple key presses. 
However, the mouse may still be necessary to make the PGT windows active in the 
desktop environment of your chosen platform.

Note that the SPACEBAR may be used in place of the ENTER key in the sections 
which follow.

3.5.1 Input Focus
To move the input focus from one item in a panel to another, press the TAB key on 
the keyboard. Repeatedly pressing this key will cause the input focus to move to 
each item in turn. To reverse the direction in which the input focus cycles, hold 
down the SHIFT key whilst pressing the TAB key.

3.5.2 Menus
Look at Fig. 6 and notice that the initial letter of each of the menu names on the 
menu bar is underscored. The underscored letter can be used in combination with 
the ALT key to open the menu. For example, to open the Panel menu, hold down 
the ALT key and press the P key.

Figure 6   Accessing Menus Using the Keyboard

Once a menu is open, the UP-ARROW and DOWN-ARROW cursor keys can be 
used to highlight entries in the menu. To select an entry, use the cursor keys to 
highlight it, then press the ENTER key. Alternatively, just press the letter key 
which corresponds to the underscored letter for the menu entry you wish to select. 
For example, to select the Reset entry in the open Panel menu, just press the R key. 
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Similarly, to open the Print submenu, press the T key. Note that any letter in the 
name of the menu entry may be underscored, not just the initial letter.

Some menu entries have keyboard shortcuts (known as accelerators) which are 
shown to the right of the entry in a menu. For example, to reset the contents of the 
Observation Details Panel (Fig. 6) press and hold the CTRL (Control) key then 
press the R key. This can be done whenever the window is active, that is, you do 
not need to open a menu first. A complete list of keyboard accelerators is shown in 
Appendix A.

3.5.3 Pick-Lists
To open a pick-list using the keyboard, press the TAB key until the pick-list gains 
the input focus (see section 3.4.2, page 8, and section 3.5.1, page 9) then press the 
ENTER key. To traverse the list, use the UP-ARROW and DOWN-ARROW cursor 
keys. When your chosen entry is highlighted, press the ENTER key to select it.

3.5.4 Buttons and Check Boxes
A button can be activated by pressing the TAB key until the button has the input 
focus (see section 3.4.2, page 8, and section 3.5.1, page 9), then pressing the 
ENTER key. To toggle the state of a check box, press the TAB key until the check 
box has the input focus, then press the SPACEBAR (not the ENTER key).

3.5.5 Textfields
To enter text into a textfield, ensure it has the input focus (see section 3.4.2, page 
8, and section 3.5.1, page 9) before typing. Some textfields only allow numbers to 
be entered, others will allow any character. All textfields have a maximum number 
of characters (including spaces and carriage returns) which may be entered and you 
will hear a beep when this limit is reached. Some textfields also limit the number 
of lines which may be entered i.e. you can press ENTER only a limited number of 
times. Note that textfields may sometimes resize themselves within a panel while 
you type. This allows the components in a panel to make the best use of the 
available space for the input you have entered.

3.6 Exiting the Proposal Generation Tool

The PGT can be exited by selecting the Exit menu entry from the File menu in the 
Main Panel (see Fig. 7), or by pressing and holding the CTRL key and then pressing 
the E key while the Main Panel is active.
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Figure 7   The File Menu

 If you have made changes to your proposal, you will be asked if you would like to 
save your proposal before exiting.

Figure 8   The Quit Dialogue

Click Exit to quit
the PGT

Click Yes to open the Save
dialogue and save your
proposal

Click No to exit the PGT
without saving your changes

Click Cancel if you do not
want to exit the PGT
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4 Saving, Loading and Printing

4.1 Saving

A proposal may be saved at any time by selecting the Save menu entry in the File 
menu of the Main Panel (see Fig. 7). This will cause the Save dialogue to appear.

Figure 9   The Save Dialogue

The Save dialogue allows you to navigate around a local filesystem. The area in the 
centre of the display shows the files and directories contained in the current 
directory. The current directory is shown in the pick-list at the top of the display. 
You can move between directories by double clicking on a directory icon or by 
choosing a directory from the pick-list.

To save your proposal, type a file name into the box provided and click the Save 
button. This will save your proposal into the directory shown at the top of the 
display using the file name you gave.

If you change your mind about saving a proposal, click the Cancel button.

4.2 Loading

To load a proposal, select the Open menu entry in the File menu of the Main Panel 
(see Fig. 7). The Open dialogue will appear and this looks very similar to the Save 
dialogue, described above. Indeed, you can navigate around your local filesystem 
in exactly the same way as you would in the Save dialogue.

When you locate the proposal you wish to load, either double click on its name in 
the file list, or click once on the name (the name will appear in the File name: box) 
and click the Open button.

Current directory

List of files in
current directory

File name for saved
proposal

Click the Save button
to write the proposal
to the specified file

Click Cancel to close the
Save dialogue without
saving the proposal

Move one level up
the directory tree

Go to the “home”
directory

Create a new
folder/directory

Use the pick-list to make
quick jumps to other
directories
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Figure 10   The Open Dialogue

4.3 Printing

4.3.1 The Print Options Dialogue
The paper size and the font used for printing can be chosen using the Print Options 
dialogue. To open this, select the Options menu entry from the Print submenu in 
the File menu of the Main Panel (see Fig. 7).

Figure 11   The Print Options Dialogue

Two paper sizes are supported, A4 and US letter. Click on the appropriate button at 
the top of the dialogue to choose the paper size.

The central part of the dialogue lists the fonts available on your system. This list 
will vary from one machine to another, but there are five standard fonts which are 
available on every system. These are: Dialog, DialogInput, Monospaced, SansSerif 
and Serif. A sample of the selected font is shown below the font list.

To make the selected font and paper size the current (active) choices, click the OK 
button. To disregard the selections and close the dialogue, click the Cancel button.

Double click on the
proposal name to load
it into the PGT

If you click once on
the proposal name, click
the Open button to load
it into the PGT

Select paper size here

Choose the font by
clicking on its name

Click the OK button when
you are happy with your
choice

Click Cancel to discard
your selection and use
the current settings
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4.3.2 Printing an Entire Proposal
To print a complete proposal, including all observations, choose the Proposal menu 
entry from the Print submenu in the File menu of the Main Panel (see Fig. 7). A 
Print dialogue will appear which will allow you to select a destination for the print 
job (printer or file) and to start the print job. The exact appearance of this dialogue 
will depend on the platform you are using.

4.3.3 Printing Admin Details
The data entered in the Admin Details Panel (see section 5.2, page 15) can be 
printed separately by choosing the Print menu entry from the Panel menu of the 
Admin Details Panel.

4.3.4 Printing Proposal Details
The data entered in the Proposal Details Panel (section 5.3, page 16) can be printed 
separately by choosing the Print menu entry from the Panel menu of the Proposal 
Details Panel.

4.3.5 Printing Observations
The Print submenu in the Panel menu of the Observation Details Panel (see Fig. 6) 
allows you to print individual observations or all the observations in the proposal.

To print an individual observation, make sure the observation is displayed in the 
Observation Details Panel (see section 5.4, page 17) and choose the Current 
Observation menu entry from the Print submenu, described in the previous 
paragraph. To print all the observations, choose the All Observations menu entry 
from the same menu.

4.3.6 Printing the Observation Summary
A summary of all the observations in the proposal (one observation per line) can be 
printed by choosing the Summary menu entry from the Print submenu in the Panel 
menu of the Observation Details Panel (see Fig. 6).
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5 Entering Data

5.1 The Main Panel

When the PGT is first started, it is the Main Panel which is displayed. This panel 
acts like the parent for all other panels and it is from this panel that you can access 
the other panels which make up the PGT.

Figure 12   The Main Panel

The Main Panel is divided into two sections. The top half of the panel contains 
buttons which open other panels. These panels are described in later sections of this 
document. In addition, there is a Check Proposal button which will run through a 
series of checks on your proposal and list anything which is wrong or incomplete. 
This check can be performed at any time.

The lower half of the Main Panel is devoted to proposal submission. With the 
Submit Proposal to ISOC button you are able to electronically send your proposal, 
via the Internet, to the ISOC. See section 7, page 24, for more details on submitting 
a proposal.

5.2 The Admin Details Panel

To open the Admin Details Panel, select the Admin Details Panel button on the 
Main Panel. When the panel first appears, only the upper part of the body of the 
panel is visible. To see the lower part, click in the empty space below the scrollbar 
on the right-hand side of the panel.

} These buttons open other
panels in the PGT

} This section allows you to
submit or resubmit your
proposal

Press this button to check your proposal
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Figure 13   The Admin Details Panel (upper part)

The Admin Details Panel contains fields which are used for administrative 
purposes. They are self-explanatory. The lower part of the panel concerns co-
investigators and data distribution. As this is also self-explanatory, the lower part 
of the panel is not shown in this document.

5.3 The Proposal Details Panel

To open the Proposal Details Panel, select the Proposal Details Panel button on 
the Main Panel (see Fig. 12). As with the Admin Details Panel, this panel is sized 
to show only the upper part of the body of the panel when first opened.

5.3.1 Attaching the Scientific Justification

At the bottom of the Proposal Details Panel is a button marked New Attachment.

Figure 14   Adding Attachments

Click here to
see the lower
part of the
panel
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Pressing this button will open the Attach dialogue, a dialogue very similar to the 
Open dialogue described in section 4.2, page 12. You can use this dialogue to attach 
a scientific justification, but only if the file containing your scientific justification 
is in PostScript or PDF format.

Figure 15   The Attach Dialogue

Once you select the Attach button, the name of your attachment will be shown in 
the Current Attachment box of the Proposal Details Panel (see Fig. 14). If you save 
your proposal, the attachment will be saved with it (in compressed form), so there 
is no need to re-attach the file every time the proposal is loaded. However, if you 
make changes to your scientific justification after attaching the file to your 
proposal, you will need to re-attach the changed file.

Note that it is not possible to remove an attachment on its own (you can select Reset 
from the Panel menu and this will remove the attachment, but it will also clear the 
other fields). However, you can replace the existing attachment with another one at 
any time, simply by using the Attach dialogue again.

5.4 The Observation Details Panel

To open the Observation Details Panel, select the Observation Details Panel 
button on the Main Panel (see Fig. 12). As with the Proposal Details Panel, this 
panel is sized to show only the upper part of the body of the panel when first 
opened.

5.4.1 Observation Numbering

Each observation in a proposal is numbered sequentially, as shown in the Number 
field on the left of the tool bar at the top of the panel (see Fig. 16). Here, you can 
see the number of the currently displayed observation and the total number of 
observations in the proposal.

Whenever an observation is added to a proposal, it is added at the end of the list. 
For example, adding an observation to a proposal which contains ten observations 

Attachments must be
in PostScript or PDF
format
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will result in the new observation being given the number eleven. When removing 
an observation, those observations with a higher number than the observation 
which was removed will have their numbers reduced by one. For example, 
removing observation number five from a proposal which contains ten observations 
will result in observation numbers six to ten being renumbered five to nine 
respectively.
 

Figure 16   The Observation Details Panel (upper part)

5.4.2 Displaying Observations

Only one observation may be displayed at a time. To display a different 
observation, use the navigation buttons on the tool bar. The First button always 
causes observation number one to be displayed. The Last button causes the last 
observation which was added to the proposal to be displayed (this is always the 
observation with the highest number, because observations are always added to the 
end of the list). The Next button causes the current observation number to increase 
by one, i.e. pressing this button repeatedly will cause each observation to be 
displayed in numerical order. The Previous button works in the reverse manner to 
the Next button, i.e. the current observation number will be decreased by one. Note 
that this button does not necessarily return you to the observation you were looking 

Navigation buttons

The current
observation
number and
the total number
of observations
in the proposal

The sum of the
durations in all
observations in
this proposal

Click here to
see the lower
part of the
panel

Tool bar
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at previously, so if the proposal contains three or more observations and you click 
the First button, then the Last button and then the Previous button, you will not be 
looking at observation number one, but rather, observation number n-1, where n is 
the number of observations in the proposal.

5.4.3 The Observation Menu

The Observation Details Panel has an additional menu, named Observation.

Figure 17   The Observation Menu

Using this menu you can manipulate observations in your proposal. The menu 
entries should be self-explanatory: to add a new observation, select Add (the 
display will show the new observation); to remove the currently displayed 
observation, select Delete; to copy the currently displayed observation, select 
Duplicate (the display will show the copied observation); to check the currently 
displayed observation, select Check; to display a particular observation, select Go 
To.

5.4.4 Instrument Settings

In the lower half of the Observation Details Panel you can choose certain 
instrument settings. The number of modes and parameters available will depend on 
the privileges allowed in the version of the PGT you are using. For example, the 
General Observer (public) version of the PGT only allows two parameters for the 
JEM-X 2 instrument to be set and the choice of two modes for the OMC instrument.

If an instrument has only one mode available for selection, the Mode pick-list for 
that instrument will be disabled, as there is no choice to make. Similarly, if there 
are no parameters to set for an instrument, the Parameters button for that 
instrument will be disabled.

5.4.5 JEM-X TM Formats
If you click the Parameters button for the JEM-X 2 instrument, the Mode 
Parameters panel for that instrument will be displayed. This panel allows you to set 
the Primary and Secondary TM Formats. The allowed Secondary TM Formats are 
dependent on the Primary TM Format selected and correspond to a matrix of 
allowable Primary and Secondary TM Format combinations, see RD-10 and RD-
11.
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Figure 18   JEM-X 2 Mode Parameters Panel

The list of Secondary TM
Formats varies depending
on the choice of Primary
TM Format

Current observation
number
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6 Online Tools

Two online tools are provided to aid proposal writing: the Observation Time 
Estimator (OTE) and the Target Visibility Predictor (TVP). To use either tool, your 
computer must be connected to the Internet.

6.1 Observation Time Estimator

Figure 19   The OTE Panel

Inputs to the OTE should be chosen from the pick-lists and/or entered into the boxes 
provided. Some boxes have mutually exclusive relationships between them; they 
are the Continuum Energy and Line Energy boxes, and the Signal to Noise and 
Exposure Time boxes. For example, if you enter a value into either of the 
Continuum Energy boxes, the Line Energy boxes will be disabled. To re-enable the 
Line Energy boxes, delete the text from the Continuum Energy boxes. Similarly, if 
you enter a value into the Signal to Noise box, the Exposure Time box will be 
disabled. To re-enable the Exposure Time box, delete the text from the Signal to 
Noise box.

The PGT will not perform any checking of the values you enter (all checking is 
performed remotely by the OTE), so you should note the following points:

• One of either the Signal to Noise or Exposure Time fields must be completed
• The OTE will accept values in exponential format e.g. 1e-6 or 1E4
• The Signal to Noise ratio should be entered as a number i.e. 3 not 3:1
• The Right Ascension and Declination fields are optional and may be left 

blank

When you have completed all the relevant fields and you wish a calculation to be 
performed, click the Fetch Results button. The PGT will then attempt to contact 

Click the Fetch Results
button to send your
inputs to ESTEC. The
results will appear in
a separate panel.
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ESTEC, via the Internet, and pass your inputs as arguments to the OTE running 
remotely on a machine at ESTEC. When the calculation has been performed, the 
OTE will return the results and they will be displayed in a separate panel.

To perform another calculation, change the inputs as required and click the Fetch 
Results button again. The results will be displayed in a new panel, leaving your old 
results available for comparison.

6.2 Target Visibility Predictor

Figure 20   The TVP Panel

Inputs to the TVP should be chosen from the pick-list and/or entered into the boxes 
provided.

The PGT will not perform any checking of the values you enter (all checking is 
performed remotely by the TVP), so you should note the following points:

• The Right Ascension and Declination may be entered in two formats: either 
as a decimal value in degrees, or as hours:minutes:arcseconds (for RA) or 
degrees:minutes:arcseconds (for DEC), where the values are separated by 
colons or spaces. If you include the sign (either + or -) for Declination, make 
sure there is no space (or any other character) between the sign and the de-
grees value

• All fields must be completed

When you have filled in all the relevant fields and you wish a calculation to be 
performed, click the Fetch Results button. The PGT will then attempt to contact 
ESTEC, via the Internet, and pass your inputs as arguments to the TVP running 
remotely on a machine at ESTEC. When the calculation has been performed, the 
TVP will return the results and they will be displayed in a separate panel (see Fig. 
21).
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To perform another calculation, change the inputs as required and click the Fetch 
Results button again. The results will be displayed in a new panel, leaving your old 
results available for comparison.

Figure 21   TVP Results Panel

6.3 Printing Results

If you wish to print the results of a calculation made by the OTE or the TVP, it is 
recommended that you select the “Monospaced” font, using the Print Options 
dialogue (see section 4.3.1, page 13). This will ensure that columns line up properly 
and will make the printout more readable.

Example
results
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7 Submitting a Proposal to ISOC

The PGT allows you to send your proposal electronically to the ISOC. In order for 
this to work, your computer must be connected to the Internet.

7.1 Submitting for the First Time

The lower half of the Main Panel (see Fig. 12) allows you to submit your proposal 
to the ISOC when it is complete and you are happy with it. 

Clicking the Submit Proposal to ISOC button starts the submission process. First, 
the PGT will check your proposal. If it fails any checks, the submission process will 
be aborted and you will need to correct the errors shown in the Failed Checks Panel. 
If it passes the checks, a panel is displayed showing a summary of the  proposal. 
Click Submit to send the proposal, Cancel to abort the submission.

Figure 22   The Summary Panel

If you click Submit, the PGT will attempt to establish contact with a computer at 
the ISOC which has been set up to receive proposals. Once contact is established, 
your proposal will be sent. If the proposal was sent successfully, the dialogue 
shown in Fig. 23 will be displayed.

Figure 23   Successful Submission Dialogue

When it receives your proposal, the computer at the ISOC will check the proposal 
(these checks are different from those performed by the PGT) and return an email 
message to you confirming receipt and providing a Proposal ID for your proposal 
(you will need this ID if you want to resubmit the proposal). The message will also 
tell you whether your proposal has been accepted (it passed the checks) or rejected 
(it failed the checks).
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7.2 Repeating a Submission

If you realise you have made a mistake, or you just want to make changes to a 
proposal you have already submitted, you can resubmit a proposal using the 
Proposal ID you received when you submitted the proposal for the first time.

Make the changes you wish to make to the proposal and enter the Proposal ID in 
the box provided at the bottom of the Main Panel (see Fig. 12). The Resubmit 
Proposal to ISOC button will be enabled and the Submit Proposal to ISOC 
button will be disabled (to prevent you pressing the wrong button). When you click 
the Resubmit Proposal to ISOC button, the PGT will repeat the proposal 
submission process, described in section 7.1.

The computer at ISOC will use the Proposal ID you provide to find your old 
proposal in the ISOC database. If it is found, your amended proposal will replace 
the old one in the ISOC database. If it can’t be found, the email message which is 
returned to you will inform you of that fact (make sure you have entered the 
Proposal ID correctly).

NOTE: The PGT cannot prevent you submitting the same proposal multiple times. 
Each time you submit a proposal, you will receive a new Proposal ID. It is not 
possible to undo a submission, so if you want to avoid having duplicate (or very 
similar) proposals in the ISOC database (each of which will be reviewed by the 
TAC), use the Resubmit Proposal to ISOC button when you need to make 
changes to a previously submitted proposal.

7.3 Obtaining a Copy of a Submitted Proposal from ISOC

Once you have submitted your proposal, you should save it (see section 4.1, page 
12) to ensure you have a copy on your local system for your own reference, or to 
allow you to resubmit the proposal at a later date.

However, life is full of surprises and mistakes happen occasionally, so if you 
accidentally delete your proposal, or your machine catches fire, do not despair! You 
can request a copy of your proposal by sending an email to the ISOC Helpdesk at 
the email address shown in section 1.5, page 1. Just state in the body of the message 
that you would like a copy of your proposal and give the Proposal ID of the 
proposal. The proposal will be emailed to you at the email address you entered into 
the proposal. If this email address is wrong, you should provide the correct address 
in your email to the Helpdesk.

7.4 Transfer of the Scientific Justification

In exceptional cases the scientific justification can be sent to ISOC by using ftp.
This may be done by arrangment with the help desk. 
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8 Extra Features

8.1 Autosave

To prevent you losing precious hours of work through a problem with your 
computer, an autosave feature is available which will automatically save your 
proposal every so often. The frequency at which your proposal is saved and the file 
name used for the saved proposal can be defined by you.

The autosave feature is enabled by editing the PGT.lax file in your PGT installation 
directory. Open the PGT.lax file in an editor and find the following lines:

AutosaveSeconds=0
AutosaveFile=

By default, the autosave feature is disabled. To enable autosaving, set the 
AutosaveSeconds variable to a value which represents the number of seconds you 
would like to elapse between successive saves of your proposal. For example, to 
have your proposal automatically saved every five minutes, edit the line to read:

AutosaveSeconds=300

You must also specify a filename for the saved proposal by editing the 
AutosaveFile variable. For example, to save the proposal as “my_proposal” in a 
directory called “tmp” (which must already exist) on the top level of your disk 
drive, you would edit the line as follows:

On a UNIX system:

AutosaveFile=/tmp/my_proposal

On a Windows system:

AutosaveFile=C:/tmp/my_proposal

NOTE: Use / (slash) characters, not \ (backslash) characters and do not put spaces 
around the = (equals) symbols.

8.2 Changing the Mandatory Item Colour

By default, the background colour for mandatory items is cyan. This can be 
changed by editing the PGT.lax file found in your PGT installation directory. Open 
the PGT.lax file in an editor and find the following line:

MandatoryItemColour=Cyan
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The colour specified to the right of the equals symbol may be set to one of the 
following values:

Black, Blue, Cyan, DarkGray, Gray, Green, LightGray, Magenta, Orange, Pink, 
Red, White or Yellow.

NOTE: These names are case sensitive. Do not put spaces anywhere on the line.

The text colour is always black, so setting MandatoryItemColour=Black is not 
terribly useful. Similarly, the non-mandatory colour is always white, so setting 
MandatoryItemColour=White means you will not be able to tell the mandatory 
items from the non-mandatory items.



esa
INTEGRAL

ISOC

Proposal Generation Tool SUM

Doc.No : INT-SOC-SUM-018
Issue : 1.2
Date : 9th  June  2004 
Page No : 28
Appendix A: Keyboard Shortcuts

A.1 Main Panel

Table 1: Main Panel Keyboard Shortcuts

Key Press Function

ALT-A Open the Admin Details Panel

ALT-C Check Proposal

ALT-E Open the Observation Time Estimator

ALT-F Open the File menu

ALT-F E Exit the PGT

ALT-F O Open the Open dialogue

ALT-F P Open the Print submenu

ALT-F P O Open the Print Options dialogue

ALT-F P P Print the Proposal

ALT-F S Open the Save dialogue

ALT-H Open the Help menu

ALT-H A Open the About dialogue

ALT-H O Open the Overview Panel

ALT-H N Open the Main Panel Help

ALT-O Open the Observation Details Panel

ALT-P Open the Proposal Details Panel

ALT-V Open the Target Visibility Predictor

CTRL-E Exit the PGT

CTRL-H Open the Main Panel Help

CTRL-O Open the Open dialogue

CTRL-S Open the Save dialogue



esa
INTEGRAL

ISOC

Proposal Generation Tool SUM

Doc.No : INT-SOC-SUM-018
Issue : 1.2
Date : 9th  June  2004 
Page No : 29
A.2 Admin Details Panel

Table 2: Admin Details Panel Keyboard Shortcuts

A.3 Proposal Details Panel

Table 3: Proposal Details Panel Keyboard Shortcuts

Key Press Function

ALT-H Open the Help menu

ALT-H N Open the Admin Details Panel Help

ALT-H O Open the Overview Panel

ALT-P Open the Panel menu

ALT-P E Close the Admin Details Panel without losing data

ALT-P R Reset the Admin Details Panel fields to their default settings

ALT-P T Print the admin details

CTRL-E Close the Admin Details Panel without losing data

CTRL-H Open the Admin Details Panel Help

CTRL-P Print the admin details

CTRL-R Reset the Admin Details Panel fields to their default settings

Key Press Function

ALT-H Open the Help menu

ALT-H N Open the Proposal Details Panel Help

ALT-H O Open the Overview Panel

ALT-P Open the Panel menu

ALT-P E Close the Proposal Details Panel without losing data

ALT-P R Reset the Proposal Details Panel fields to their default settings

ALT-P T Print the proposal details

CTRL-E Close the Proposal Details Panel without losing data

CTRL-H Open the Proposal Details Panel Help

CTRL-P Print the proposal details

CTRL-R Reset the Proposal Details Panel fields to their default settings
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A.4 Observation Details Panel

Table 4: Observation Details Panel Keyboard Shortcuts

Key Press Function

ALT-H Open the Help menu

ALT-H N Open the Observation Details Panel Help

ALT-H O Open the Overview Panel

ALT-O Open the Observation menu

ALT-O A Add an observation to the proposal

ALT-O C Check the current observation

ALT-O D Delete the current observation from the proposal

ALT-O G Go to a specific observation

ALT-O U Copy an observation and add it to the proposal

ALT-P Open the Panel menu

ALT-P E Close the Observation Details Panel without losing data

ALT-P R Reset the Observation Details Panel fields to their default settings

ALT-P T Open the Print submenu

ALT-P T A Print the details of all observations

ALT-P T C Print the details of the current observation

ALT-P T S Print a summary of all observations

CTRL-E Close the Observation Details Panel without losing data

CTRL-H Open the Observation Details Panel Help

CTRL-P Print all observation details

CTRL-R Reset the Observation Details Panel fields to their default settings
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A.5 Observation Time Estimator Panel

Table 5: OTE Panel Keyboard Shortcuts

A.6 Target Visibility Predictor Panel

Table 6: TVP Panel Keyboard Shortcuts

Key Press Function

ALT-F Fetch Results

ALT-H Open the Help menu

ALT-H N Open the OTE Help

ALT-H O Open the Overview Panel

ALT-P Open the Panel menu

ALT-P E Close the OTE panel without losing data

ALT-P R Reset the OTE panel fields to their default settings

CTRL-E Close the OTE panel without losing data

CTRL-H Open the OTE Help

CTRL-R Reset the OTE panel fields to their default settings

Key Press Function

ALT-F Fetch Results

ALT-H Open the Help menu

ALT-H N Open the TVP Help

ALT-H O Open the Overview Panel

ALT-P Open the Panel menu

ALT-P E Close the TVP panel without losing data

ALT-P R Reset the TVP panel fields to their default settings

CTRL-E Close the TVP panel without losing data

CTRL-H Open the TVP Help

CTRL-R Reset the TVP panel fields to their default settings
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